前言

CentOS7上的Git版本太陈旧,在使用过程中会遇到问题,因此需要升级git版本。实时上,CentOS系统上各种软件版本都很低,使用的时候可能造成不同的错误,所以就需要升级了

当前系统版本

# cat /etc/redhat-release 
CentOS Linux release 7.6.1810 (Core)

git版本

# git --version

git version 1.8.3.1

安装依赖

源代码安装和编译git,需安装一些依赖

# yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel asciidoc

# yum install  gcc perl-ExtUtils-MakeMaker

卸载旧版本

# yum remove git

编译安装Git

Git软件包可在此获取:https://mirrors.edge.kernel.org/pub/software/scm/git/

我们选择最新版的:git-2.9.5

安装步骤

# cd /usr/local/src/

# wget https://mirrors.edge.kernel.org/pub/software/scm/git/git-2.9.5.tar.xz

# tar -xvf git-2.9.5.tar.xz

# cd git-2.9.5/

# make prefix=/usr/local/git all

# make prefix=/usr/local/git install

# echo "export PATH=$PATH:/usr/local/git/bin" >> /etc/profile

# source /etc/profile

验证版本

# git --version

git version 2.26.2

Q.E.D.